Problem after upgrading to Visual Studio 2010/.NET Framework 4

Jun 21, 2011 at 8:15 PM

Hi,

My application was working fine under VS 2008/.NET Framework 3.5; I just upgraded to Visual Studio 2010/.NET Framework 4 and now I'm getting an error: Extension .nc is not registered in the factory.

I added references to:

System.Reflection;
Microsoft.Research.Science.Data;
Microsoft.Research.Science.Data.CSV;
Microsoft.Research.Science.Data.Imperative;

I read your comment on the same problem and I tried adding the DataSetFactory.RegisterAssembly...line of code by it's also giving me an error; can't find DataSetFactory.

Any assistance is much appreciated.

Marilyn

 

Jun 21, 2011 at 10:07 PM

Update:  I added Microsoft.Research.Science.Data.Factory.

Now I'm getting this error:  Could not load file or assembly 'Microsoft.Research.Science.Data.NetCDF4, Version=1.26754.0, Culture=neutral, Public Key Token=e550de0161496f12' or one of its dependencies.  The system cannot find the file specified.

Where should I put the netcdf4.dll file?

Marilyn

 

Jun 22, 2011 at 6:51 PM
DamaDeNoche wrote:

My application was working fine under VS 2008/.NET Framework 3.5; I just upgraded to Visual Studio 2010/.NET Framework 4 and now I'm getting an error: Extension .nc is not registered in the factory.

Development of .Net Framework 4 applications using SDS is supported. I think that it doesn't work in your case because you upgraded the Visual Studio after installing SDS.

You should try to re-install the SDS distributive. Take the full package from the Microsoft Research site.

Jun 22, 2011 at 6:55 PM
DamaDeNoche wrote:

Update:  I added Microsoft.Research.Science.Data.Factory.

Now I'm getting this error:  Could not load file or assembly 'Microsoft.Research.Science.Data.NetCDF4, Version=1.26754.0, Culture=neutral, Public Key Token=e550de0161496f12' or one of its dependencies.  The system cannot find the file specified.

Where should I put the netcdf4.dll file?

Marilyn

 

Please read my post at this discussion: http://sds.codeplex.com/discussions/249318

Jun 22, 2011 at 8:05 PM

Hi,

Thanks for the link.  The one from Codeplex site was incomplete (the dlls for netcdf4 and hdf5 didn't install).  It's running ok now using .NET 4.

Marilyn